Bugs in the new alpha version

5 replies [Last post]
zargul
User offline. Last seen 3 days 2 hours ago. Offline
Joined: 2017-05-29
Posts: 6

A quick and dirty list of bugs I discovered in 0.9.23 alpha, in order of their discovery.

Black square instead of splash screen.

Fort mode does not exist.

White instead of transparency around icons on weapon help bubbles.

Game engine died message when video finished encoding after NORMAL game quit.

Play video button does nothing (video encoded fine).

Practice rounds cannot be played (engine dies immediately).

May God be with you, Always.

KoBeWi
KoBeWi's picture
User offline. Last seen 37 min 32 sec ago. Offline
Joined: 2010-12-25
Posts: 335

zargul allegedly wrote:
Black square instead of splash screen.
What splash screen?

zargul allegedly wrote:
Fort mode does not exist.

zargul allegedly wrote:
White instead of transparency around icons on weapon help bubbles.
https://issues.hedgewars.org/show_bug.cgi?id=154
zargul allegedly wrote:
Game engine died message when video finished encoding after NORMAL game quit.
https://issues.hedgewars.org/show_bug.cgi?id=199
zargul allegedly wrote:
Practice rounds cannot be played (engine dies immediately).
https://issues.hedgewars.org/show_bug.cgi?id=216

zargul allegedly wrote:
Play video button does nothing (video encoded fine).
You may create an issue here: https://issues.hedgewars.org/enter_bug.cgi?product=Hedgewars

Theme Editor / Code contributions / WIP
"Official" themes:
Crystal | Belly | Dreamland | Sky | Factory
"Unofficial" themes:
Chalk | Bowser | GIRDERZZZ!!! | Mirage | Sudra | Zombie
Contributed themes:
Cyberspace

zargul
User offline. Last seen 3 days 2 hours ago. Offline
Joined: 2017-05-29
Posts: 6

KoBeWi allegedly wrote:

zargul allegedly wrote:
Black square instead of splash screen.
What splash screen?

When you first start the game in Windows a hedgehog with "hedgewars" written under it (with no window or anything) appears on the screen. Or used to.

zargul allegedly wrote:
Fort mode does not exist.
[img]http://i.imgur.com/TUc5yRh.png[/

HOW DID YOU DO THAT?! I am telling you with me it is totally absent! I'm working with Windows 8.1, that's probably the difference.

As for the "play video" button, can you report it? I'd rather not give anyone else my email (meaning bugzilla).

May God be with you, Always.

KoBeWi
KoBeWi's picture
User offline. Last seen 37 min 32 sec ago. Offline
Joined: 2010-12-25
Posts: 335

zargul allegedly wrote:
When you first start the game in Windows a hedgehog with "hedgewars" written under it (with no window or anything) appears on the screen.
Oh, you are right here. However, no black square appears to me, the splash is just skipped. Seems almost like the game starts faster because of this.
zargul allegedly wrote:
As for the "play video" button, can you report it? I'd rather not give anyone else my email (meaning bugzilla).
Hmm, strange, because it works for me. However, it doesn't play in game, but opens externally with your default set software. Check if you can play the video normally by double-clicking the file and then try in game. If it doesn't work, I may create the issue, although seems like it might be hard to reproduce.

Theme Editor / Code contributions / WIP
"Official" themes:
Crystal | Belly | Dreamland | Sky | Factory
"Unofficial" themes:
Chalk | Bowser | GIRDERZZZ!!! | Mirage | Sudra | Zombie
Contributed themes:
Cyberspace

zargul
User offline. Last seen 3 days 2 hours ago. Offline
Joined: 2017-05-29
Posts: 6

Yes, the video files play correctly. The recorder is functional, unfortunately right about the time I lost interest in recording hedgewars videos.

May God be with you, Always.

Wuzzy
Wuzzy's picture
User offline. Last seen 1 hour 14 min ago. Offline
Joined: 2012-06-20
Posts: 816

Quote:

Black square instead of splash screen.

Quote:

Practice rounds cannot be played (engine dies immediately).

Yeah.
There are many bugs in the first Alpha which make Hedgewars unplayable. The first alpha was admittedly very broken.
I hope these kind of game-breaking bugs should be fixed now.

I think there will be a second alpha for testing.

Quote:

White instead of transparency around icons on weapon help bubbles.

Has been fixed.

Quote:

Game engine died message when video finished encoding after NORMAL game quit.

Has been fixed.

Copyright © 2004-2017 Hedgewars Project. All rights reserved. [ contact ]