Network game problem on 2.6.32-30-generic kernel

4 replies [Last post]
julijan
User offline. Last seen 4 years 1 week ago. Offline
Joined: 2011-01-20
Posts: 8

I have installed the new kernel 2.6.32-30-generic, the game starts fine, but when I create a room, players join, all lamps are on and the "start" button doesn't work. When I click it nothing happens. Tried to reboot with the old kernel (2.6.32-26-generic) and everything worked just fine as before, so, I guess it's some change in the new kernel version.

I run linux mint.

nemo
nemo's picture
User offline. Last seen 10 weeks 4 days ago. Offline
Joined: 2009-01-28
Posts: 1861

That seems really unlikely to me. Please switch to the new kernel and see if you can reproduce.

If you can, please run hedgewars like this:

hedgewars 2>&1 | grep -v PASSWORD | tee debug.txt

And try to reproduce the bug. If you manage it, please post that debug file somewhere.

--
Oh, what the heck. 1PLXzL1CBUD1kdEWqMrwNUfGrGiirV1WpH <= tip a hedgewars dev

julijan
User offline. Last seen 4 years 1 week ago. Offline
Joined: 2011-01-20
Posts: 8

nemo allegedly wrote:

That seems really unlikely to me. Please switch to the new kernel and see if you can reproduce.

If you can, please run hedgewars like this:

hedgewars 2>&1 | grep -v PASSWORD | tee debug.txt

And try to reproduce the bug. If you manage it, please post that debug file somewhere.


I've found the problem and it's not in hedgewars. The new kernel seems to require me to reinstall my VGA driver, I did so and the game started working.

Sorry for the false alarm Smile

nemo
nemo's picture
User offline. Last seen 10 weeks 4 days ago. Offline
Joined: 2009-01-28
Posts: 1861

Oh. I see what happened.
hwengine was crashing, so you'd launch the game, and it would immediately exit.

If you had played any game where you weren't hosting you would have seen the "in game" screen and I would have guessed "engine crash"

But since we removed that for room hosts to do admin functions, I didn't catch on.

--
Oh, what the heck. 1PLXzL1CBUD1kdEWqMrwNUfGrGiirV1WpH <= tip a hedgewars dev

Zarkoo1
User offline. Last seen 11 years 39 weeks ago. Offline
Joined: 2012-09-12
Posts: 1

damn when i try to log in it says authentiocation failed Sad Smiley pls help

User login

Copyright © 2004-2024 Hedgewars Project. All rights reserved. [ contact ]